N8N API error:ECONNREFUSED after V1.0.5 update

Hello, after upgrading to v1.0.5 I now get a ECONNREFUSED error when using the n8n API account. I’m using the same API key and Base URL (http://localhost:5678/api/v1) before the upgrade.

From the Credentials list, I click on my n8n account credential and click retry and get this error. Also, my node in my backup workflow returns to same error.

Node Error:

NodeApiError: connect ECONNREFUSED ::1:5678
    at RoutingNode.runNode (/usr/local/lib/node_modules/n8n/node_modules/n8n-workflow/dist/RoutingNode.js:114:23)
    at processTicksAndRejections (node:internal/process/task_queues:95:5)
    at Workflow.runNode (/usr/local/lib/node_modules/n8n/node_modules/n8n-workflow/dist/Workflow.js:682:23)
    at /usr/local/lib/node_modules/n8n/node_modules/n8n-core/dist/WorkflowExecute.js:631:53

Information on your n8n setup

  • n8n version:1.0.5
  • Running n8n via: n8n cloud

hm, strange not sure right now why that would not work anymore if it did work in the past. Could you please try the following URL:
1 Like

Yep, that worked, and my backup executed successfully as well. Thank you!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.