N8n API on Self Host (docker compose)

I am unable to connect to my api on my self hosted instance - the connection is timing out. Seems like a firewall issue, but the instance is available through https.

I’m on 0.208 - and i remember this worked previously, without any firewall additions (though on a much older version).

Is there something that needs changed in the .env to enable api access?


Hey @Luke_Austin can you please test if using http://localhost:5678/api/v1 as the base URL works?
that way the instance can send requests to itself directly, skipping any firewall and reverse-proxy in the middle, and we can narrow down if the issue is in n8n or outside of it.

Yep - that works.

It’ll be some docker-compose / ufw wierdness, and i’ve never managed to solve any of those.

Thanks for the rapid help!


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.