N8n disabling workflow for production

Hello, I have a problem on my n8n, I get the following message:

{“code”:404,“message”:“The requested webhook “POST login” is not registered.”,“hint”:“The workflow must be active for a production URL to run successfully. You can activate the workflow using the toggle in the top-right of the editor. Note that unlike test URL calls, production URL calls aren’t shown on the canvas (only in the executions list)”}

But when I check the workflow is active, if I disable and enable it again it works again, some time later the problem returns.

Does anyone have an idea of ​​a solution?

Information on your n8n setup

  • n8n version: 0.204.0
  • Database: mysql 5.7.40
  • Running n8n with the execution process own
  • Running n8n via Docker

Welcome to the community @Carlos_Tadei!

Problems like this normally occur when multiple n8n instances run at the same time. Because then the one that turns off will remove all the active workflows. Is it possible that you run n8n in a green-blue deployment or similar?

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.