N8n Domain

Hi!

I’m trying to create a Google Sheets credential with Oauth2, but i can’t sign in because i can’t add my actual acess (myIP:5678) on authorized URI in Google Cloud (this appears)

I see in some YouTube videos that is possible to “change” the way to acess n8n using a domain, how i can do this?

Some infos:

  • I’m using a VPS with Ubuntu 22.04 64bit
  • I run n8n through docker
  • Version 1.31.1

In advance, thank you

It looks like your topic is missing some important information. Could you provide the following if applicable.

  • n8n version:
  • Database (default: SQLite):
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app):
  • Operating system:

hello @Ryan_MR3

You will need to set the ENV WEBHOOK_URL

You need to set up a proper domain that has ssl to do anything useful with n8n, since most APIs will require a valid url and ssl (https instead of http)

In my option the easiest and fastest way to set that up is with cloudflare tunnels (which is 100% free). If you know the process it takes only about 5 minutes

You will need to set the environment variables N8N_EDITOR_BASE_URL and WEBHOOK_URL to match the url, WEBHOOK_URL specifically needs the https:// prefix to work with some OAuth apps.

1 Like