N8N on Docker stopped working in the middle of the night, can't get the UI via web anymore

self hosted on digital ocean droplet

I think i screwed things up. To say I am new to all this is an understatement

Was working on tings last night and everything worked great, went to bed and woke up to find

Last thing I was doing was installing Zep for memory and getting the load balancers set up in digital ocean, which it was my first time doing that, so I might have messed that up

Everytrhing appeared to be set up corrrectly so I switched my dns, from pointing to the droplet IP to the load balancers IP.

Here is what comes up when I do the docker logs command

and docker ps gets me this

What is the error message (if any)?

503 and
This site can’t be reached

It looks like your topic is missing some important information. Could you provide the following if applicable.

  • n8n version:
  • Database (default: SQLite):
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app):
  • Operating system:

hello @djjace
Have you tried the curl http://localhost:5678/ from the docker host?

The provided logs are not related to the n8n container

1 Like

nope, where would I do that? digitalocean is the host

If the change you made is the DNS, this is probably the cause of your problem. And I wonder whether you really need a load balancer to run your n8n

the load balancer was for Zep, it was in the instructions to do so for security purposes

here is what my dns looks like now, overkill, but I am grasping at straws

digital ocean
image

my dns

SSH docker ps

I am really stressed about this. I havre about 100 hours of work in there and I have lost 2 days trying to figure this out

I see that you have an n8n listening the port 5678, but you have configured the forwarding rules to points to the port 80, that is listened by the caddy (dunno what it is). How that supposed to work?

you can run the curl command from the server, where you entered the docker ps or docker logs command (it is the docker host)

That output means that the n8n is working fine. The issue is only with port mapping or that caddy application.

As currently the schema looks like this:
You are going to the DNS name on port 443, then the balancer redirects you on port 80, that is listening by the caddy. N8n is listening only the port 5678 that is not used by the balancer and thus it won’t be accessible to you. You can change the mapping from 443 > 80 to 443 > 5678 and then the n8n should be accessible.

that did it…partially

The UI is now up, but the workflows side just keeps trying to load

what would cause the workflows to not load?

I just noticed it is working with the http but not the https

ssl issue?

Probably yes. When you changed the DNS name, have you also changed the SSL certificate?
You could see some errors if you press the f12 and look into the Network tab.

you mean like this?

Yes. The credentials page for some reason hasn’t been loaded. That’s why you didn’t see workflows. You can click on the failed page to see the details, but I assume the issue is with the certificate, as such a page usually requires the browser to set a special cookie, which usually can’t be set when the SSL is not working properly