N8n on Ubuntu 18 LTS

Hi, after install N8n on my new Server, i get this message.
Any idea ?
grafik

I have all update installed, also mmmagic !

Thanks,
Stefan

It looks like you did run npm install and/or npm run build with one Node.js version (for example 10) and you now try to start n8n with a totally different version (for example 12). That causes problems. The versions have to be the same one.
To fix that best try to delete the node_modules folders and package-lock.json files and then install and build everything again.

OK, i try it. After that , i run npm install n8n again ?

You, would do exactly the same what you did the first time you installed n8n. So you can simply follow the guide again here: https://github.com/n8n-io/n8n/blob/master/CONTRIBUTING.md#actual-n8n-setup
but this time starting from step 2 as you already have n8n checked out.

I ran into this exact same problem when I installed on Ubuntu 18 LTS. I have found that if you are going to install NodeJS, NPM, etc., use the versions that are from the actual websites, not the ones that are in he Ubuntu repository.

1 Like