N8n-pi v0.01.02 Released

Good day, n8nizens!

A quick message to announce that the latest image of n8n-pi has been released! This is a minor release with no real new functionality but it is based on the new Raspberry Pi OS (formerly Raspbian).

Here are the specs:

You can get more information and the download here.

As always, feedback is appreciated.

5 Likes

Hello I like this concept however I have a Rpi4. I tried version 1.01 and 1.02 and after introducing the password I get:

jq: error: Could not open file /usr/lib/node_modules/n8n/package.json: No such file or directory. /etc/update/motd.d/11-n8n exited with return code 2

I wonder what could be the issue?

EDIT:
it works even with this error. Sorry I didn’t realize the browsing was on my network (other pc) instead of the Pi device. Thanks for creating this!

Hey @realstylishguy! Welcome to the community.

First, thanks for testing this on a RPi4. I have not had the chance to give it a go yet. This is good feedback.

The error that you are seeing is a script that runs each time you log into the system. It is looking for the version number of n8n to display in the message of the day. You can bypass this error by doing the following:

  1. Open up /etc/update/motd.d/11-n8n in your text editor of choice when logged in as root
  2. Insert a # in front of line 12 (N8NVER=$(jq -r .version /home/n8n/.nodejs_global/lib/node_modules/n8n/package.json) should now read # N8NVER=$(jq -r .version /home/n8n/.nodejs_global/lib/node_modules/n8n/package.json)) to comment out this line
  3. Insert a # in front of line 20 (echo "${CYAN}n8n Version....: ${white}${N8NVER}" should now read # echo "${CYAN}n8n Version....: ${white}${N8NVER}") to comment out the output line
  4. Save the file

The next time you reboot, the error should disappear.

3 Likes

Hi @Tephlon I wanted to say thanks. However, from time to time I’m getting the following error.

Problem
There was a problem and the workflow could not be deactivated:
SQLITE_FULL: database or disk is full

then the workflows go red/inactive and display:

Problem activating workflow
Sorry there was a problem. No error got found to display.

My configuration is the same as before. The raspberry pi continues to be responsive (SSH) while all this happens. So far the issue kinda gets solved by doing a reboot on the pi multiple times a day but that’s the only solution I’ve found so far and it’s less than ideal. Any advice would be greatly appreciated.

@realstylishguy not sure if I understand correctly. You want to say that it says the disk is full but it is actually not full?

image

Well, sorry if I wasn’t clear enough. I’ve been looking for tutorials on the following but I haven’t had luck. I don’t mind if there is any tutorial/guide you could recommend. I’m just not familiar with Linux to be honest.
By looking at this picture:

  1. I guess I don’t have much free room? My SD is 32gb but I don’t see this adding up to 32gb…
  2. Where does n8n store the files? (in terms of partition, folder location)
  3. How to clean the temporary files from nodes often? (Automatically if possible)

Sadly no idea how this image is build but it seems like you have actually only 2 GB for / where it saves more or less all your data. Currently only 1.8 MB are still free. So it seems like the message is totally correct that the disk is simply full. If you say that you have 32 GB available you probably have to assign also the other 30 GB to ‘/’ to be able to use them.

Apart from that you can make sure that it only saves the executions that fail instead of all of them as documented here:
https://docs.n8n.io/reference/configuration.html#execution-data-error-success

Not really a fix but at least it should make temporary sure that it does not run full as fast.

image
I’ve now manually changed the values to none
image
but because disk is full I can do literally nothing at all. I cannot even even free space by deleting old WorkflowExecutions from the GUI.


I just wanted to point out that it seems there’s no exit from here.
When Disk gets full:

  • Cannot disable workflows so disk doesn’t keep getting full
  • Cannot delete stored workflow executions

I guess I’ll just download my workflows and start fresh and import them back. Please be advised of the dead end mentioned above. Thanks

Sorry for not responding back quicker. Have been on vacation without Internet access! :scream:

If you built this from the downloaded image, it is possible that the compression process that I use has shrunk the partition. To make the partition use all of the space on your SD card, log in as the n8n user and issue the sudo raspi-config command. This will bring up a menu system. Find the Expand Filesystem option and then reboot your system after it has been expanded.

You should now see more free space!

Hopefully this solves your issues.

3 Likes

image
Excellent. Thank you so much to both. Nodemation is a great project. I’m sharing how good all this is with my friends. Keep it up

3 Likes