N8n pruning is not working

Describe the problem/error/question

We have a self hosted n8n setup in queue mode. When we started, we did not setup pruning environment variables. Our executions count has now grown to 10 million. Now we are trying to setup pruning environment variables but pruning is not happening. We have waited for 2 days but it has not worked. I want to know if this is normal for such a huge count of executions? Also if I directly go to Postgres DB and delete the records from n8nexecution_entity will it work?

Following are the environment variables I have setup -
EXECUTIONS_DATA_PRUNE = true
EXECUTIONS_DATA_MAX_AGE = 1440
EXECUTIONS_DATA_PRUNE_MAX_COUNT = 4000000

What is the error message (if any)?

No error logs present

Please share your workflow

(Select the nodes on your canvas and use the keyboard shortcuts CMD+C/CTRL+C and CMD+V/CTRL+V to copy and paste the workflow.)

Share the output returned by the last node

Information on your n8n setup

  • n8n version: 0.214.2
  • Database (default: SQLite): Postgres
  • n8n EXECUTIONS_PROCESS setting (default: own, main): Queue mode
  • Running n8n via (Docker, npm, n8n cloud, desktop app): docker
  • Operating system: Ubuntu

Unfortunately we can’t provide community support for older versions like 0.214.
Have you tried upgrading to a newer version?
Data pruning has been completely rewritten in the last months, and upgrading to the latest release might help solve this issue.