No able to access the Telegram Bot demo

@TheLiveChatBot doesn’t react to /start command

1 Like

It looks like your topic is missing some important information. Could you provide the following if applicable.

  • n8n version:
  • Database (default: SQLite):
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app):
  • Operating system:

Hi @Gad_Benisty, welcome to the n8n community!

Can you provide a little more context here please? Which demo are you following?

1 Like

Is this related to n8n in any way?

No idea, this is given by you as an example there : Advanced Telegram Bot, Ticketing System, LiveChat, User Management, Broadcasting | n8n workflow template

1 Like

Ah, thanks!

@anas it looks like your telegram bot is down.

1 Like

I have updated it now, and it is working well. The issue is with the Telegram API as they have changed their parameter’s visibility, so the topic title is not displayed with replies. I have updated the forwarding node and the template as well.

If you already clone the template and made your changes and need to resolve this issue, this how to fix:

Open the HTTP node titled “Forward Support Reply To User” and replace the http call with this new one:

https://api.telegram.org/bot{{ $('Bot-Config').item.json.BotToken }}/forwardMessage?chat_id={{ $json["reply_to_message_forward_from_id"] || $('Bot-Fields').item.json.reply_to_message_forum_topic_created_name.match(/\[id:(\d+)\]/)[1] }}&from_chat_id={{ $('Bot-Config').item.json["Support_Group_ID"] }}&message_id={{ $('Bot-Fields').item.json["message_id"] }}
2 Likes