Node running out of memory while n8n still has a lot of ram left

Describe the issue/error/question

Trying some community nodes, puppeteer, and python nodes, the python node always through oom error message, please see below.
I am trying to get some help to see if I miss any configs.

What is the error message (if any)?

ERROR: Execution stopped at this node
n8n may have run out of memory while executing it. 

Please share the workflow

Information on your n8n setup

  • n8n version: 0.218.0
  • Database you’re using (default: SQLite): Postgres
  • Running n8n with the execution process [own(default), main]: own
  • Running n8n via [Docker, npm,, desktop app]: Docker in Nomad cluster

Hey @keajer,

Does the n8n output in docker also show the memory being used?

The puppeteer node would start an instance of chrome so that can use memory if it is not being closed and I am not too sure on the Python node.

We typically only directly support the nodes we ship with, I would assume as you are using puppeteer and Python are you also using a custom n8n image rather than one of the ones we distribute?

there isn’t any stdout in n8n container.
is there a way to force close the instance after I got the output data?
Yes, I build my own n8n image, but its on top of n8nio/n8n:latest

That is odd normally there would be some output, the message you are seeing typically means the workflow has crashed the most likely cause is memory but it could be something else.

Can you enable debug logging and see if that shows anything? I would also maybe try your image with just puppeteer and then another with just Python to see if that has any issues.

I suspect puppeteer will be ok as I have an instance running using that but it is always possible that something is causing it to trip up. In your workflow when it runs which is the currently active node when you see the message and have you tried running each node one at a time in the flow?

you were right, I got
Cannot read properties of undefined (reading 'main')
when the node crashed.
Like you said the puppeteer runs fine, main issue is from the python node.

So it could be an issue with the node or some data is not right going into it. Have you tried a simple hello world in it to confirm that works?

It may be worth raising an issue on the GitHub repo for the node so the node creator can take a look as well, could just be that the import isn’t valid and the node output isn’t going to the right place.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.