Noob Question while giving custom api call

Below is custom api request

i have validated the body parameters they are valid json but still n8n is giving json error

{ "status":"created",
"pickup_date_time":"2022-11-07 14:30",
"remarks":"fragile items",
"chargeable_weight_carrier":45 ,
"source_warehouse_name":"Spinefit Medical Pvt Ltd",
"source_address_line1":"102 B Ujwal Sherene Baner",
"source_address_line2":"Near Mauli Garden","source_pincode":"411045",
"sender_contact_person_name":"Spinefit Medical",
"sender_contact_person_email":"[email protected]", "sender_contact_person_contact_no":"9569999953",
"destination_warehouse_name":"SNAS IOT LABORATORIES PRIVATE LIMITED", 
"destination_address_line1":"Asha Nikum ",
"destination_address_line2":"Asha Nikum ",
"destination_city":"Ujjain ",
"destination_state":"Madhya Pradesh ", "recipient_contact_person_name":"SNAS IOT LABORATORIES PRIVATE LIMITED", "recipient_contact_person_email": "", 
"recipient_contact_person_contact_no":"9131073367", "delivery_partner":"gati",
"packaging_unit_details":[ {"units":1,
"weight":45, "length":125, "height":80, "width":45,
} ], 

Hi @Spinefit, welcome to the community :tada:

I am sorry to hear you’re having trouble. It seems your workflow requires quite a bit of additional data to reproduce the problem you are having as your expression seems to reference fields from several other nodes. I suspect one of these values causes the JSON structure to break.

Perhaps you can consider defining individual fields in the HTTP Request node, like so?

This way, n8n should build a proper JSON structure based on the available data.

i have shared the final json data also which i checked it was valid json
but i dont knw some how it started showing error all of sudden

Which n8n version are you running @Spinefit? I tried running your example on [email protected] against a site not expecting any authentication and it completed just fine:

Also, have you tried setting the individual values over trying to manually build a valid JSON string? Did you get the same error with this approach?