Notion cannot read properties of null

Since 211.1 of n8n, I’m getting this error in the Notion node. I have tried other databases and other events. Same result.
Previously I was using the n8n-python docker image, and thought it might be the cause of this error, so I reverted to the official n8n image and the same results.

This is the node.

Information on your n8n setup

  • n8n version:211.2
  • Running n8n via Docker:

EDIT: I also tried other workflows, and creating a new one from scratch, but the issue persists, this only happens with the Notion Trigger Node, the main Notion node works just fine.

I am also seeing this issue on 2 instances of n8n, with 2 different notion accounts, and both new and existing workflows. I’m going to revert back to 0.210.2

I am also facing this issue.

Hi all, thanks so much for reporting this and sorry for the trouble.

This issue is currently in our engineering backlog awaiting a fix.

A fix has been merged and should be available with the next n8n release:

2 Likes

@MutedJam Thanks! Appreciate y’all getting to it so quickly!

2 Likes

Hey folks, we just released [email protected] which should fix the notion trigger problem.

2 Likes

Wow! That was pretty quick
Thanks to you all.
:grin:

EDIT: I can confirm the issue is resolved

2 Likes

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.