Notion "Get many" unusual (and cool) simple output without "property_" prefixes

When one has to use simple Notion “get many DB pages” output, the result is property_name1, property_name2 and so on. For Cyrillic users there’s still no way to use simple output — these characters can’t just be added after “properry_”.

But I have an unusual simple output of DB with Cyrillic property names. And no “property_” prefix. Unfortunately, this is the only case. I wonder how I could use this on a regular basis?

Hey @artildo,

You have lost me there, In your screenshot it looks like you are using the Simplify option and I can’t see an issue there, Do you maybe have more screenshots to show the issue you are seeing?

Hi @Jon

This is the issue. Please see 2 screenshots.

In “usual” simplified output we have props starting with “property_”

If Notion props contain Cyrillic characters, we have this bug (I reported i t long ago). The output prop is singular. This is the same DB, I just renamed the properties

So in my first topic not only I avoid this bug, but also my properties are not starting with usual “property_” prefix. And this is cool but seems like another bug )

Now I am even more confused :slight_smile:

So to try and get my head around this… We had a bug and it looks like that is fixed but now it doesn’t say property_ before it and you want that back?

@Jon , let me put it case by case.

We have an DB_Eng with 3 Eglish props (Name, Status, Date). And we have the same DB_Cyr, but with props in a Cyrillic language (Russian in my case: Название, Статус, Дата)

  1. Simple output of DB_Eng contains three properties: property_name, property_status, property_date. This is normal output, as expected.

  2. Simple output of DB_Cyr contains only ONE property: property_. This is a n8n bug which I reported long ago and still not fixed.

  3. My current case. Simple output of DB_Cyr contains all needed properties with names without “property_” prefix. So in n8n these properties are given as in Notion: Название, Статус, Дата. And I like this approach but this is unintended behavior. I can’t replicate it with other DBs.

Hey @artildo,

So with case 2 and 3 you have said you are using simple output for DB_Cyr but case 2 has a bug that you reported which is not fixed and case 3 even thought it is the same test it is working but you don’t have property_ at the start and this same thing doesn’t happen for DB_Eng.

I have a feeling that either case 2 or case 3 should be “not simple”, I will do some testing and see if I can work out what is actually going on here.

@Jon, yeah, it’s better to try.

Yes, case 3 is unique and works even better then Case 1, because instead of “property_status” I have just a “status”. But I have just 1 case of this Notion node for case 3. It even looks a little bit odd.