Notion - "Select" Field - Create/update behavior differs


I followed the thread here but can’t figure out how to fix the issue on database page update

When I create a new database page, all select field can be defined using an expression returning the selected “label” (new labels are automatically created).

But when I use the “update page” action, it ends up with a 400 error (… should be defined…)
I tried using the Select “Id” value instead but it got same error.

Actually, it seems to work intermittently as the exact same action can be successfull sometimes…

  • n8n version: 0.172.0
  • Database: Mysql
  • Running n8n with the execution process: default
  • Running n8n via: Docker

Hey @airmoi, seeing this works intermittently for you, is there a chance you’re passing multiple items on to your Notion node and your expressions only working for some of them?

Hey @MutedJam,

That was it !
I had a previous step which was searching for the page in the database to get its ID, but I had duplicated rows so it ended up with 2+ rows. The Status was calculated using the $node[“Start”] which, in fact, returned a non-existent index for the second+ rows
I was able to fix it using $items(‘Start’)[0] instead

1 Like

Perfect, glad to hear this worked! Thanks so much for confirming :slight_smile: