Npm run build not successful

Describe the bug

npm run build not successful

To Reproduce

  1. git clone

  2. Cd n8n

  3. lerna bootstrap --hoist

  4. Npm run build(stuck in the step)

    1. Core module and workflow module build succeeded

    2. Editor UI module has been loading on building for production


  • OS: OSX Catalina 10.15.7
  • n8n version: last git commit hash 69a013d7
  • Node.js version: v14.17.1

Welcome to the community @Fan!

Does the computer you try to build n8n on have access to the internet?

1 Like

Thanks for your reply. It has access to the internet when I build n8n.I have tried many times to excute npm run build, but every time I get stuck at Building for production.

And I try to enter the editor-ui folder, run npm run serve. Still stuck at 70%.

Still sounds to me like it can not access the internet to download the fonts. You can try to comment out the following lines and then try again:

1 Like

This is indeed the problem :joy:, thanks again for your reply.

1 Like

Happy to hear that it worked. Have fun!

Hi. I had been stuck with this error all day until I got here, now it works for me too. Thank you. But please, how did you know it was this plugin fonts causing trouble? I just try to learn here for the future.

Welcome to the community @gu1ll3901nation !

I honestly only knew because I am often programming offline in cars, planes and trains and so knew that problem.

Well, I guess it was lack of experience. Now I know too that could happened. Thanks again.