Numerous issues with global npm installation of n8n

Describe the problem/error/question

There are several related problems with my webhook, Square API integration, probably all caused by a single, core issue.

  • Workflow executions sometimes “stick” and won’t go away. My instance of n8n crashed and when I restarted it, there were three workflow executions that showed as still running, even though they no longer existed. I tried deleting the contents of the execution_entity sqlite table, but it STILL showed those executions. I came back two hours later and they had strangely disappeared.
  • Execution retries ALWAYS use the old code, not the currently saved code.
  • I’ll get webhook requests which trigger an execution, and they won’t show up in the execution log for a while, then will suddenly appear. I’ve tried stopping and restarting n8n but no joy.
  • I’ve tried deleting a workflow, and it doesn’t delete. Then I try deleting it again and it says it’s not owned by me.

What is the error message (if any)?

Please share your workflow

Share the output returned by the last node

Information on your n8n setup

  • n8n version: 0.224.4
  • Database (default: SQLite): SQLite
  • n8n EXECUTIONS_PROCESS setting (default: own, main): default
  • Running n8n via (Docker, npm, n8n cloud, desktop app): npm
  • Operating system: CentOS

Hey @dcasale,

How many of these were resolved by not going through the reverse proxy?

Hi Jon. I’m still going through reverse proxy, but forcing the server to expire all requests seems to have solved the problem.

Here’s how I did it:

<Proxy *>
    Order deny,allow
    Allow from all

<Location "/">
    <IfModule mod_passenger.c>

    # Needed for SSE events
    ProxyPreserveHost On
    # Proxy to port 5678 on localhost
    ProxyPass http://localhost:5678/
    ProxyPassReverse http://localhost:5678/
    # Force all HTTP request expiration
    ExpiresActive On
    ExpiresDefault "now"
    Header set Cache-Control "no-cache, must-revalidate"    env=no-cache-headers
    Header set Pragma        "no-cache"                     env=no-cache-headers
    Header set Expires       "Sat, 1 Jan 2000 00:00:00 GMT" env=no-cache-headers
# Don't proxy the .well-known folder, to allow SSL certs to be auto-renewed
<Location /.well-known/*>
   ProxyPass !

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.