OAuth URL not working / not showing up

Describe the issue/error/question

Currently, my web hook URL for any credentials is showing as “https://./rest/oauth2-credential/callback” but I have my web hook tunnel and URL set in the .env file, I also manually attempted to change them away from the .env variables for my docker-compose file. This was working just fine before the last update so I’m unsure why this is occurring.

I’ve also tried specifying “WEBHOOK_URL” instead of “WEBHOOK_TUNNEL_URL”

Information on your n8n setup

  • n8n version:
    [email protected]
  • Database you’re using (default: SQLite):
  • Running n8n via [Docker, npm, n8n.cloud, desktop app]:

Hi @Alex_Witkowski, welcome to the community :tada:

I am really sorry to hear you’re encountering this behaviour but was unfortunately not able to reproduce it. Could you share your whole docker compose file (with anything confidential redacted of course)?


I switched from .env for a bit to try to fix this issue but that’s included too.

The update somehow fixed it. It may just have been restarting the server that did that.


Awesome news, thanks so much for confirming!