On Postman, "401 Authorization is required!" on a self-hosted n8n instance

Describe the issue/error/question

I can’t make any requests to the self-hosted n8n instance from Postman,

I can’t also make request to self-hosted n8n from the workflow that is in same URL;

I used the same info that is written in Swagger UI


Although I can reach from Swagger UI which is accessible on the self-hosted url;



I can’t figure out why it is giving me “401 Authorization is required!” error on Postman although I’m giving the api key on the header?

Information on your n8n setup

  • n8n version: self-hosted Version 0.209.4

I solved it!

It needed basic auth for self-hosted n8n and header auth for my workflow.

When I enter both, it worked;


1 Like

To add, if you swap to user management instead of the basic auth. You will not need to have both anymore. :wink:

Hi again @BramKn :slight_smile:

And where can I swap to user management? :slight_smile:

Thank you!

not 100% sure.

I know someone had a similar question not too long ago. But I think it might be in Discord, so harder to find.
Removing the env variables for the basic auth setup is a starting point.
Maybe a reset is needed after. But I am not sure. Might be good to wait for someone to respond to this. Or open a specific topic for this question so it can be used as a reference for others as well.

reset is talked about here:

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.