OpenAI in Chat mode shows mode like error

When I choose Chat → Complete, I see the default mode (as a dropdown). Bit then it’s just becomes like an error with no dropdown. But still working.

This was reported internally yesterday but I was not able to reproduce this, When you added the node did you select the Chat Completion option from the actions list and did you already have the credentials set?

Can you also confirm the version of n8n you are running, I did make a change to that a couple of versions ago.

@Jon, made some test: on a single OpenAI-node workflow

I wasn’t able to get the same bug.

Started as a Chat completion. Changed to Text, and it doesn’t change the Model (and model list). After closing/opening again this was fixed

Switching from Text to Chat: same bug. The model list is updated only after c;losing/opening the node, when the option are renewed.

Hey @artildo,

That kind of makes sense as the field has the same name and it doesn’t load when you swap between them. I believe this is more of a core thing than the node itself but I will have a think about what we could do to change this.

Maybe the trick is to not worry about loading the models from OpenAI but then we would have to show everything rather than just what your API key has access to.

@Jon another annoying thing happening sometimes is non-changeable resourses.

Here I can’t choose the Chat mode. It simply doesn’t change: It stuck to Text and can’t be changed to another Resource
Workaround: choosing Custom API call operation and then I can switch to Chat.

1 Like

Hey @artildo,

That is something I found the other day as well, still need to write it up in the internal tracker.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.