Over 6 seconds delay with EXECUTIONS_PROCESS=own?

I have a simple workflow - just a webhook, query to baserow and returning the output.

Is this expected behavior, that with EXECUTIONS_PROCESS=main I get quite fast reply:

time curl https://n8n.mydomain.org/webhook/test?value=1
{"name":" Ada","lastName":" Lovelace"}
real	0m1.170s
user	0m0.010s
sys	0m0.008s

and with own, It takes over 6 seconds more?

time curl https://n8n.mydomain.org/webhook/test?value=1
{"name":" Ada","lastName":" Lovelace"}
real	0m7.948s
user	0m0.008s
sys	0m0.009s

Information on your n8n setup

  • n8n version: 0.226.2
  • Database (default: SQLite): MariaDB
  • n8n EXECUTIONS_PROCESS setting (default: own, main): both
  • Running n8n via (Docker, npm, n8n cloud, desktop app): docker
  • Operating system: Ubuntu 22

Hey @Shalak,

Welcome to the community :tada:

This is partially to be expected although the delay for the workflow to actually start is normally around 1 - 3 seconds depending on hardware. We briefly mention this in the docs here: Execution modes and processes - n8n Documentation

1 Like

Hello! Yeah, I saw that, but did not expect to be over 6s - that feels really bad. I’m running this in 8 vCore + 16 GB RAM VM on Proxmox, that has 2x E5-2450L. If I set the webhook node to respond immediately, I get ~1s, just like with EXECUTIONS_PROCESS=main.

I’m wondering if there is any optimization I could do to improve this…

Hey @Shalak,

You might be able to make some changes to docker itself, In my test environment I get ~ 3 seconds without changing anything. You would be better off using main and if you were worried about the instance falling over queue mode would be the best approach to take.

There could be some information out there on what docker settings could be tweaked to make the most of your hardware but we don’t really have anything in n8n itself.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.