Paused nodes make manual executions working bad

Describe the problem/error/question

If I have a paused node, manual executions run in an unpredicted way.

Run a node which is earlier then the paused one.

Then:

  • Running the node right after the paused makes the whole process to re-execute.
  • Running a not-adjacent node outputs no result - the paused node blocks the data flow

What is the error message (if any)?

No error. I expect that the paused nodes are simply ignored and the rest of the nodes keep on with executing

Please share your workflow

Share the output returned by the last node

Information on your n8n setup

  • n8n version: 0.236.0
  • Database (default: SQLite): default
  • n8n EXECUTIONS_PROCESS setting (default: own, main): main
  • Running n8n via (Docker, npm, n8n cloud, desktop app): Docker compose
  • Operating system: Ubuntu 22

Hi @artildo, I’m sorry you’re having trouble.

I tried running your test workflow, however, executing the final node is working fine for me with your Set node disabled:

ezgif.com-video-to-gif(1)

Were you perhaps doing anything different when encountering this problem?

1 Like

@MutedJam, thank you for having a look. However, you testing it wrong. Please take a look at the screenshot above. You need to execute some nodes BEFORE the paused one. Then try to execute nodes after the paused one.

The result well be either full re-run, or simply not executing. Ans I expect that simple the next node will be executed and so on.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.