Paypal 'listener' node not working?

Describe the problem/error/question

I have been trying to connect my paypal account to n8n. As such I am using the ‘paypal trigger’ node. Which, to my understanding functions largely like a webhook but with the POST & header information abstracted away.

I am having errors performing test listens, and getting the published workflows to capture webhook events emitted from paypal.

All my API deets are correct and there is definitely a successful connection. The paypal trigger node has an included ‘filter’ functionality to filter on type of webhook, which I have set to ‘*’ wildcard. However I also tried specific events just to try rule out whether the wildcard wasn’t working.

What is the error message (if any)?

When using this paypal trigger node, I can get it to receive test events using the paypal developer test environments and webhook simulator, but when I switch paypal to the live environment, I can’t get it to capture any webhook events whether using the webhook-test url or the webhook url of the node. My api details for both live and test credentials are correctly set & configured too.

Additionally, when I create a new workflow and perform a test to the webhook-test url, it will no longer allow me to publish or activate that workflow. I get an error that says “Workflow could not be activated: Resource id is invalid”.

If I don’t perform a test listen, and simply publish & activate my workflow straight away, it doesn’t result in that error (albeit though it still doesn’t work by receiving any webhook events from paypal).

Something is definitely buggy.

In the end, I opted to just use the regular old webhook node. Which obviously doesn’t allow me to filter by paypal event - but at least I can receive stuff.

Information on your n8n setup

  • **n8n version:**latest
  • **Database (default: SQLite):**default
  • **n8n EXECUTIONS_PROCESS setting (default: own, main):**default
  • **Running n8n via (Docker, npm, n8n cloud, desktop app):**docker/easypanel
  • **Operating system:**ubuntu

Hi @jatacid, I am very sorry for this. It looks like you have already reported this problem in another thread, and this bug is already with our engineering team. We’ll post an update on the original thread once a fix is available.