PayPal Trigger: Works in Sandbox, but Returns "Resource ID is invalid" in production

What is the error message (if any)?

“Resource ID is Invalid” when turning the node to Active. Events list is populated in node editor.

Please share the workflow

Share the output returned by the last node

Information on your n8n setup

  • 0.165.1
  • Database you’re using (default: SQLite):
  • Running n8n with the execution process [main]:
  • Running n8n via Docker

Hey @Luke_Austin, the screenshot suggests an unexpected HTTP status was returned when PayPal tried to send the webhook. Is your workflow marked as active? Otherwise n8n would respond with a 404 status code to webhooks coming in on the production URL.


Hi @MutedJam - yeah, the node runs when i click “execute node”, but doesn’t pick up “mock” webhook data generated by PayPal.

It throws the error when I try to turn the scenario into “Active”.

Are you perhaps using sandbox credentials then? Could you try switching from “Sanbox” to “Live” in your PayPal credentials?


Hi @MutedJam - yep checked, triple checked the credentials, the webhook URLs and the modes.

I’m stumped!

I am still seeing this - anyone know of a fix?
The paypal node just doesn’t like to be activated for some reason

Hi @jatacid, I am so sorry. I was able to reproduce the problem just now and will add it to our bug tracker for a closer look and fix.

Hey @jatacid,

I have just tried to give this a go but I was not able to reproduce this on 1.2, Could you update and let me know if it is still an issue?