PipeDrive Node : Can't Get more than 100 fields for deal update

Hello

If you want to update a deal, custom fields are not retrieved after the first 100 fields. Pipe drive use pagination for Access to more data, but the pipedrive node does not paginate.

PipeDrive API return : “additional_data”:{“pagination”:{“start”:0,“limit”:100,“more_items_in_collection”:true,“next_start”:100}}}

So if user have more custom fields, he won’t be able to find them after the first 100, any fix or workarround for this ?

Hi @Seb33, welcome to the community :tada:

From taking a brief look at the code this is unfortunately the expected behavior currently. n8n sends a single request to Pipedrive fetching the list of custom properties and no pagination is implemented for this.

I’ve converted your question into a feature request so you and other community members can have a say on adding this functionality.

As for a workaround, you could use an expression to specify the custom field ID yourself. Add an expression like so in n8n:
image

Then, as the value of the expression, use the API identifier which you can copy from Pipedrive in the data fields settings:

Thanks for the time :slight_smile: i’ll use your work arround !

1 Like