Pipedrive -) The field "Organization Name or ID" get "The value is not supported!"

Describe the issue/error/question

Hey, I’m updating my Pipedrive workflow and found out that what use to be 2 different fields are now merge into 1.

The “Organization Name or ID” is giving me trouble.

I cannot seems to be able to update this field by using an expression. Fixed values work just fine.

I’m not sure if I’m suppose to use the expression for the organization ID or the expression for the Name ID. I tried both and both seems to not work.

One particullar thing about the name of the organization is that they are made out of number only, so I was wondering if the system just does not know when one is the name or the ID because both are in numbers.

What is the error message (if any)?


  • The value “180” is not supported!

Please share the workflow

Share the output returned by the last node

Information on your n8n setup

  • version 1.92.2n8n version:

Hi @Come, can you still execute the node despite the warning? I tried this on my side and the workflow would seem to run fine, despite the message:

Hey, thank you for your answer.

I can still execute the node despite the warning Yes.

And it happens to make change to my pipedrive but the wrong change.

Despite the false warning, I think the problem might be different than what I originally said.

The problem is that both the name and the id are merge into the same field so when the name of my organization is made out of number, which is the case a lots of time, it get pick up as the id and the name of the org get change to a completly different name.

Would you happen to know where I can ask that they change this field and divided it into 2 rather than one ?

The error : * The value “…” is not supported! -) is still a problem for future users as well

it is still a problem for me… any insights @MutedJam

Hi @para_ops, welcome to the community! What exactly happens when you specify a valid org ID in the field?

thanks @MutedJam - we are using a different integration , the consistent issue is “the value “” is not supported”. when I enter a fixed value it runs as it should. I need a value to be pulling from the preceding node though

We’re introducing a new parameter to solve the problem that @Come had, where you can explicitly specify that the expression you’re providing is an ID. It might take a little while to get to the Pipedrive node, but I believe this should fix the issue.