Postgres node long running


first of all, thanks for the amazing product, we use it a lot @merqueo, but we recently moved from 0.25.1 to 0.69.1 and have issues with a lot of our trivial workflows that involve postgreql nodes (cron->refresh materialized view->slack).

The thing is that the postgresql node is executed, but we never got it realized because the slack node isn’t. We have to stop looong running (hours) workflows time to time, but they haven’t changed since the version upgrade. Here is a screeshot of the execution times (all executions above 60 mins were cancelled by hand).

Our question is, are there any parameter/configuration that can control/monitor this type of behaviour?


1 Like

Welcome to the community @Nickmancol! Great to hear that you enjoy using n8n at merqueo!

Very sorry to hear that you have problems! Did you check out the breaking changes here?

Not totally sure if I understand the problem. What node is making problems and does not finish? And what is that node doing?

P.S. You should probably make sure to delete some old executions. It sits now at over 21k :wink: Maybe also a good idea to only save the executions which did fail in the future.