Predefined Zoho Authorizations Not Working For HTTP Client

As the Zoho Node doesn’t contain a Custom API call or the ability to find an account with anything besides the ID, I have been trying to use the HTTP Client as suggested, though when using the Predefined Authorizations as I do with others, it fails each time.

The error message that comes back is

“status”:“rejected”,

“reason”:{

“message”:“Authorization failed - please check your credentials”,

“timestamp”:1709513932424,

“name”:“NodeApiError”,

“description”:“401 - “{"code":"INVALID_TOKEN","details":{},"message":"invalid oauth token","status":"error"}\n””,

“context”:{

},

“cause”:{

“message”:“401 - “{"code":"INVALID_TOKEN","details":{},"message":"invalid oauth token","status":"error"}\n””,

“name”:“Error”,

“stack”:“Error: 401 - “{"code":"INVALID_TOKEN","details":{},"message":"invalid oauth token","status":"error"}\n” at createError (/usr/local/lib/node_modules/n8n/node_modules/axios/lib/core/createError.js:16:15) at settle (/usr/local/lib/node_modules/n8n/node_modules/axios/lib/core/settle.js:17:12) at IncomingMessage.handleStreamEnd (/usr/local/lib/node_modules/n8n/node_modules/axios/lib/adapters/http.js:269:11) at IncomingMessage.emit (node:events:525:35) at IncomingMessage.emit (node:domain:489:12) at endReadableNT (node:internal/streams/readable:1358:12) at processTicksAndRejections (node:internal/process/task_queues:83:21)”

}

}

}

The workflow in question is
{
“meta”: {
“instanceId”: “de772d85f0b6fd464ab1f7cb54178e4f2f402562f47b07ae62216ed48ac68365”
},
“nodes”: [
{
“parameters”: {},
“id”: “a552755a-96a0-4575-8a0c-feffd55fad05”,
“name”: “When clicking "Execute Workflow"”,
“type”: “n8n-nodes-base.manualTrigger”,
“position”: [
820,
380
],
“typeVersion”: 1
},
{
“parameters”: {
“operation”: “executeQuery”,
“query”: “select count(distinct EVENT_ID), domain from DATA_WAREHOUSE.DS_EXTENSION where se_action in (‘Page view’,‘starts’,‘start’) and DERIVED_TSTAMP_AEST > current_timestamp - interval ‘30 day’ and source not like ‘%internal%’ group by 2 order by 1 desc”
},
“id”: “c5e6c184-b386-47ad-a7d5-c7543a827877”,
“name”: “Snowflake”,
“type”: “n8n-nodes-base.snowflake”,
“position”: [
1040,
380
],
“typeVersion”: 1,
“credentials”: {
“snowflake”: {
“id”: “26”,
“name”: “Snowflake account”
}
}
},
{
“parameters”: {
“batchSize”: 1,
“options”: {}
},
“id”: “67390e6b-372c-43b0-8259-b43c58db94e1”,
“name”: “Split In Batches”,
“type”: “n8n-nodes-base.splitInBatches”,
“position”: [
1220,
380
],
“typeVersion”: 2
},
{
“parameters”: {
“url”: “=https://www.zohoapis.com/crm/v6/settings/fields?module=Accounts&Snowflake_Domain=‘{{ $node["Split In Batches"].json["DOMAIN"] }}’”,
“authentication”: “predefinedCredentialType”,
“nodeCredentialType”: “zohoOAuth2Api”,
“options”: {}
},
“id”: “103432f5-6915-4ee5-969d-63bb8da6a900”,
“name”: “HTTP Request”,
“type”: “n8n-nodes-base.httpRequest”,
“typeVersion”: 3,
“position”: [
1440,
280
],
“credentials”: {
“zohoOAuth2Api”: {
“id”: “39”,
“name”: “Zoho account 2”
}
}
}
],
“connections”: {
“When clicking "Execute Workflow"”: {
“main”: [
[
{
“node”: “Snowflake”,
“type”: “main”,
“index”: 0
}
]
]
},
“Snowflake”: {
“main”: [
[
{
“node”: “Split In Batches”,
“type”: “main”,
“index”: 0
}
]
]
},
“Split In Batches”: {
“main”: [
[
{
“node”: “HTTP Request”,
“type”: “main”,
“index”: 0
}
]
]
}
}
}




## Information on your n8n setup
-Version 0.221.2
- **Database - Unsure

It looks like your topic is missing some important information. Could you provide the following if applicable.

  • n8n version:
  • Database (default: SQLite):
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app):
  • Operating system:

Hey @LBAdam,

If you are running 0.221.2 I would recommend upgrading first then see if it is still an issue.