Prevent multiple 'run' on one node

Describe the issue/error/question

So I am trying to create a “jump-like” scenario, for now I broadcast things to every connection. However, in a situation like below the last node would be run 4 times.
Is it possible to prevent it from executing multiple times or is there a better way to achieve this?

Please share the workflow

Information on your n8n setup

  • n8n version: 0.173
  • Database: Postgres
  • Running n8n via Docker

Hey @cccc,

You can tell the node under the settings to only run once which may do what you are after.