Problem Excecuting a workflow thoroughly

I am working on a workflow that sends data from a sheet to an HTTP call.
the problem is that the HTTP call doesn’t get activated! All the other steps woks fine except Http call!
I’ve demonstrated it in this screenshot.
I am using the latest version of N8N via docker on Ubuntu 22.04.

It looks like your topic is missing some important information. Could you provide the following if applicable.

  • n8n version:
  • Database (default: SQLite):
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app):
  • Operating system:

I assume the “problem” is that the node “Google Sheets1” does not output any items. As an n8n node executes once per item by default the workflows stops executing if there is nothing to process (no items => nothing to do).

If the node “SMS Reminder” does not depend on the data of the node “Google Sheets1”, you can active “Always Output Data” on the node “Google Sheets1”. n8n will then output an empty item if there is nothing and so ensures that the workflow keeps on executing past that point.

2 Likes

@Mohammadali_Mo you can do always output data in settings of sheets node see if that helps

1 Like