Problem executing workflow There was a problem executing the workflow: "Cannot read properties of null (reading '$error')"

I have this flow, here’s part of it

Now, this node:
image

keeps giving me this error
image

Its the same as the node above it which works ok, making the same calls etc and there are results coming from if IF node, I tried adding a no op after true false as I’ve seen that bug before, but it didn’t help.

I have no idea why it thinks there is no output from the node before?

Hey @RedPacketSec, unfortunately it’s really hard to understand what might be happening here with just screenshots rather than the actual workflow. Is there any chance you can share a simplified workflow using which your problem can be reproduced?

yeah let me get something knocked up

1 Like

ok try this

Hey @RedPacketSec, thanks so much!

From taking a first look it seems this could be related to the HTTP Request not returning valid JSON for all URLs you’re calling. As a workaround you could set the Response Format to String:

n8n will still understand the JSON response (but will move it under the data key, so you might need to adjust the following nodes a little), but would no longer complain about the non-JSON items:

ahh interesting, the error message was less than useful, but that makes sense. cheers will give it a go.

1 Like

yeah that allowed me to pull back the data, thanks.

1 Like

Glad to hear this worked and I very much agree on the error message. I don’t think it’s intended, so have added it to our internal bug tracker for a closer look.

1 Like