Problem loading credentials after instance update to 1.14.2

Describe the problem/error/question

Hello, we have updated our self-hosted n8n instance to version 1.14.2 and flows have a problem now. Any connection I open or try to edit, closes immediately and I get the following error: Problem loading credential: Malformed UTF-8 data:

image

image

Is there something we can do to bulk-restore them or should we add again all connections manually?

Thank you,
Alex

Information on your n8n setup

  • n8n version: 1.14.2
  • Database (default: SQLite): custom postgresql
  • Running n8n via (Docker, npm, n8n cloud, desktop app): Docker

Same here! I re-started my n8n instance (since I’m having issues with endless running workflows…), when I wanted to log in to my n8n instance again, my password wasn’t accepted. Then I tried to set a new password and got the error message “Malformed UTF-8 data”. So I’m not able to access n8n anymore… what’s the problem here?

I did a migration to a new n8n instance, problem resolved.

Does downgrading to 1.12.2 fix this ?

having the same issue on 1.15.2

1 Like

All credentials are corrupted, we had to recreate each record

How did you migration, export and import credentials?

You can find a pretty nice explanation on exporting & importing workflows/credentials here: CLI commands | n8n Docs

@alexnemes what version were you on before upgrading to 1.14.2?

Yes, this fixed it for me. Anything later than 1.12.2 throws errors with encryption.

Why is this the case? I can’t see anything that was listed as a breaking change in the release notes. How do I go about getting it operational properly on the latest release?

Chiming back in here as I’ve managed to resolve this in my environment and have now been able to upgrade beyond 1.12.2.

I discovered a discrepancy in the encryption key between what was specified in the environment variable and what was in the config file.

I’ve actually just removed the config file, and everything appears to be working fine again.

Guessing after 1.12.2 something was changed and the config file was being used instead of the environment variable, even though the environment variable was specified.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.