Problem to updating mongoDB

when I send 2000 requests to my database (mongoDB) it will works and 2000 rows will be added to DB but in my workflow the node is still in progress and don’t let next node to be run until at least half an hour
how can I manage it?

It looks like your topic is missing some important information. Could you provide the following if applicable.

  • n8n version:
  • Database (default: SQLite):
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app):
  • Operating system:

Hey @amir,

Can you tell me how you are running n8n?

At a guess you are self hosting and using nginx as a reverse proxy, If this is the case I suspect your nginx reverse proxy settings have not been configured to support websockets correctly which means the front end is not getting the update to let it know the workflow has finished.

I tried to batch my request but I don’t know if it have a problem
take a look please