Problem upgrading n8n docker

Hello
I am getting started with n8n and really enjoying constructing workflows in n8n. Unfortunately I am new at docker and running into a snag. This is about upgrading n8n in the docker and not so much about any particular workflow.

I have n8n 1.9.3 running which is now several months old. Today when I try to update it, I did

docker pull n8nio/n8n

Then I stopped my old containers and tried to start new ones with docker compose. The n8n container encounters a problem and won’t start.

docker log shows it restarting continually and ‘command akp not found’ each time.

# docker logs 254b622c9088
 ›   Error: command akp not found
 ›   Error: command akp not found
 ›   Error: command akp not found
 ›   Error: command akp not found
 ›   Error: command akp not found
 ›   Error: command akp not found
 ›   Error: command akp not found

Any pointers how to deal with this one?

Thanks

Mark Hagler

It looks like your topic is missing some important information. Could you provide the following if applicable.

  • n8n version:
  • Database (default: SQLite):
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app):
  • Operating system:

Hey @markhagler,

Welcome to the community :tada:

Can you share your compose file? I am not sure why it would be running the akp command as I don’t don’t think it is something we do so it could be a configuration issue that needs to be updated.

I wonder if maybe your compose file is using a command to try and install something and it is using akp instead of apk :thinking:

Hello Jon
Thank you for your reply, and correct suggestion! I’m sorry I didn’t think to look more closely at the docker compose yaml but yes, for some reason somebody on our team had edited this file and was apparently trying to use ‘apk’ and it was just a typo.

  n8n:
    user: root
    image: docker.n8n.io/n8nio/n8n:latest
    restart: always
    ports:
      - "127.0.0.1:5678:5678"
    labels:
      - traefik.enable=true
      - traefik.http.routers.n8n.rule=Host(`${SUBDOMAIN}.${DOMAIN_NAME}`)
      - traefik.http.routers.n8n.tls=true
      - traefik.http.routers.n8n.entrypoints=web,websecure
      - traefik.http.routers.n8n.tls.certresolver=mytlschallenge
      - traefik.http.middlewares.n8n.headers.SSLRedirect=true
      - traefik.http.middlewares.n8n.headers.STSSeconds=315360000
      - traefik.http.middlewares.n8n.headers.browserXSSFilter=true
      - traefik.http.middlewares.n8n.headers.contentTypeNosniff=true
      - traefik.http.middlewares.n8n.headers.forceSTSHeader=true
      - traefik.http.middlewares.n8n.headers.SSLHost=${DOMAIN_NAME}
      - traefik.http.middlewares.n8n.headers.STSIncludeSubdomains=true
      - traefik.http.middlewares.n8n.headers.STSPreload=true
      - traefik.http.routers.n8n.middlewares=n8n@docker
    environment:
      - N8N_HOST=${SUBDOMAIN}.${DOMAIN_NAME}
      - N8N_PORT=5678
      - N8N_PROTOCOL=https
      - NODE_ENV=production
      - WEBHOOK_URL=https://${SUBDOMAIN}.${DOMAIN_NAME}/
      - GENERIC_TIMEZONE=${GENERIC_TIMEZONE}
    volumes:
      - n8n_data:/home/node/.n8n
      - local-files:/files
    command: akp add --update python3 py3-pip

I am back in business! Thank you again for pointing in the right direction.

1 Like

Hey @markhagler,

That is good to hear, I will get the solution marked :slight_smile:

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.