Problem with expression in the HTTP request node

Hi @LorenzoSbeghen :wave:

Could you share your workflow with us by hitting ctrl/cmd + a and then ctrl/cmd + c while editing your workflow, and then pasting it here between two sets of three backticks (```)?

Could you also share your input data in JSON format? Of course, please redact anything sensitive!

And one last thing, but the following information would be helpful:

  • n8n version:
  • Database (default: SQLite):
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app):
  • Operating system:

Hi @LorenzoSbeghen - thanks for that! As your workflow requires credentials I wouldn’t have, I can’t run the workflow to get an actual example JSON. But I’m wondering if perhaps you have more than one item being returned, or an item doesn’t have a URL set?

You could add an If node before the HTTP Request Node 5, that looks like this:
image

You could then see if it’s missing data :+1:

all have url

Ah, that actually highlighted the problem - you either will need to add the item index to the Code node output, or out of HTTP Request 4, you’ll need to Split in Batches and process one at a time.

You can read more about why you need them to be individual items here: Data item linking | n8n Docs

can you help me?

Hey @LorenzoSbeghen,

Try putting the merge from the done branch on the split in batches node, You may not even need the code node depending on what you are doing. Check out the example below and see if it helps.

1 Like

Hi, it’s still not working

Which bit isn’t working? Looking at the topic here we have no actual information on what you are trying to do or what isn’t working.

The node is connected at done, shouldn’t the flow continue?

Hey @LorenzoSbeghen,

It should do unless it is trying to do something else, Can you share the full workflow along with the n8n version you are using and how you have it deployed so we can check if it is version specific.

It would also be handy to know more about what you are actually trying to do as there could be another way to handle it.

1 Like

Sorted out! The problem seems to be related to the PDF that I was trying to split, it could be something interfering with that PDF, I tested it with others and it worked.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.