Problem with HelpScout credentials

Hi n8n team,
I’m trying to connect my HelpScout account via the O2Auth.
When i click on the authorize button (helpscout page), i’m redirected to my n8n instance but i got a json error message:

{“code”:0,“message”:“The request is missing a required parameter, includes an invalid parameter value, includes a parameter more than once, or is otherwise malformed.”,“hint”:""}

In the url path, i’m on /rest/oauth2-credential/callback
And i got the code and state params as wanted.

Information on my n8n setup

  • Running n8n via Docker, and my settings uses the system of queuing.

Thanks in advance for any helps.

Hi @nma, first of all, welcome to the community!

I am sorry to hear you’re running into trouble here. I quickly gave this a go but did not run into trouble on my local instance here:

After hitting authorize:

I end up here as expected:

I’ve tested this using queue execution mode as well as regular execution mode. Can you confirm the exact version of n8n you are running?

Hi @MutedJam , thanks for your help.

I’m on the version 0.142.0.

By using the queuing system, i have two subdomain : n8n.mydomain.com and webhook.n8n.mydomain.com.

The problem is that the OAuth Redirect URL is not good for me… It results on a 404 if i let it like in the previous screenshot. I need to remove de “webhook.” in the url and tranform it to “https://n8n.mydomain.com/rest/oauth2-credential/callback”. By doing this, i don’t have a 404 error but i got the error i mentionned in my previous post. I don’t know why.

Thanks @nma, when setting the WEBHOOK_URL to another domain, I can indeed reproduce the behavior you have described. Would you be able to temporarily remove this configuration option and re-try authenticating with HelpScout?

Hi @MutedJam , it will be difficult for me. I put this settings because i got many problems with my instance who is not so powerfull and when i received a lot of webhook calls in same time, all the instance is down :confused:
If no other solution, then i will try but i try to find the source issue if possible before. Do you have an idea of what can cause this problem with this setting ?

Hi @nma - to clarify, I am not suggesting to make such a change permanently. I merely want to narrow down whether this setting is indeed the cause of the problem for you. So it would be great if you could give this a quick go during a period of low load and then revert the setting.