Problem with http request node

Hi, im trying to send to the API of MessageBird the next Parameters:

  • to (Number to send a message)
  • from (ChannelId from user of MessageBird)
  • template (template’s name from user to start conversation)
  • type (type from message, always text)
  • content (Text of the message)

I always receive this error because this parameter that the API expect to receive is a json, and the node that permit to send this paremeters don’t allow to send a json, only a parameter and her value.

The documentation from the site is here → MessageBird | API Conversations

And the URL that im trying to send the information is these →

I have already authenticated with the access_key, the problem is that parameter

You are not defining the content parameter. Also, you are defining the template, but that parameter it’s not in the docs.

1 Like

But in the node it only lets me send parameters and their values, that’s why it gives me that error.

Hey @victormiranda!

You will have to set the content type in the Header parameter. You can set the Header parameters under the Headers section.

If i put the type content in the header i receive this error.

I need to put this inside Body Parameters, and when i put this inside i recieve this other error.

You need to add the following in the Header parameter:
Name: Content-Type
Value: application/json

1 Like

Same error, i can’t do anything.

Hey, can you please share the credentials via personal message? This will help me replicate the issue and provide you a solution

It work now, i add the option JSON/RAW Parameters and insert this in Body Parameters:

“url”: “”,
“raw_url”: “”,
“method”: “post”,
“to” : “+34XXXXXXXX”,
“channelId” : “???”,
“type” : “text”,
“headers”: {
“Authorization”: “AccessKey ???”,
“Content-Type”: “application/json”
“content”: {
“text”:“Hi there, Im Using Whatsapp”

I’m so happy ajajaja, 2 days for this, but finally it works, Thanks you for your help.

1 Like