Problem with installation on DigitalOcean


I’m struggling recently with installation of n8n on DigitalOcean. After recent updates and moving installation from root to user, the process basically can be completed, but n8n is not accessible through domain.

To be precise: I run sudo docker compose up -d, containers start correctly, but n8n doesn’t open in the browser.

I’ve checked DNS records, .env file and Caddyfile - in all those files I’ve got correct subdomain. As DATA_FOLDER variable I pointed to /home/oskar/n8n-docker-caddy, where oskar is the username.

Do you know maybe where is the problem?

Hey @oskar,

Welcome to the community :cake:

If you check the docker logs is it running? I suspect if you have moved the files from one path to another if you have not updated the owners of the files you could see some permission issues in there.

Hello @Jon,

thanks for quick reply. Following your comment I checked the logs and found the problem, which is actually very easy to solve.

In recent update of n8n-docker-caddy variables N8N_BASIC_AUTH_USER and N8N_BASIC_AUTH_PASSWORD have been deleted from .env, but value of N8N_BASIC_AUTH_ACTIVE in docker-compose.yml is still by default true.

Setting N8N_BASIC_AUTH_ACTIVE to false solved the issue.

Hey @oskar,

Ah that will do it, I will check the repo now and get it updated.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.