Problem with OAuth2 API Credentials Callback

Using n8n self hosted on docker with version 0.107.0. I’m using credentials with OAuth2 API with Awair.

The initial call works but during the callback n8n does not seem to respond or proceed. I can see the callback is being done correctly in Chrome Dev Tools and with the necessary information to proceed to the token call, instead it just hangs.

Tried clicking for info in the help link about credentials but it directs me to a blank page. I found some info here: https://docs.n8n.io/nodes/credentials, unfortunately, nothing useful.

Not sure if I’m missing anything. I’m passing all necessary parameters as listed in the Awair docs. And Awair seems to be working fine and sending necessary info back.

References:
Awair docs: https://docs.developer.getawair.com

Thanks!

Welcome to the community @DoItAndBeDone

I have seen this before when the authentication parameter is not set correctly. According to the docs, the body has to be used there.

1 Like

Hmm. Well must have missed that option. So hyper focused it was invisible… It works now, thank you so much!