Problems updating N8N (Heroku hosted)

Hi! I’m super new to deploying apps on my own VPS, but loving N8N so far!

I am however facing an issue trying to update the version, currently on 0.184.0 and I deployed to heroku using this one-click button here GitHub - sarveshpro/n8n-heroku: n8n docker implementation for heroku.. I followed the npm update instructions (see below) and getting the below response, with N8N still showing 9 updates available.

Appreciate this is a rather noob question, but keen to get updated to the latest version on my own VPS (rather than the cloud/SaaS version).

Response from update command as below:

npm WARN deprecated [email protected]: request-promise-native has been deprecated because it extends the now deprecated request package, see
npm WARN deprecated [email protected]: Please upgrade  to version 7 or higher.  Older versions may use Math.random() in certain circumstances, which is known to be problematic.  See for details.
npm WARN deprecated [email protected]: The querystring API is considered Legacy. new code should use the URLSearchParams API instead.
npm WARN deprecated [email protected]: Please upgrade  to version 7 or higher.  Older versions may use Math.random() in certain circumstances, which is known to be problematic.  See for details.
npm WARN deprecated [email protected]: request has been deprecated, see
npm WARN deprecated [email protected]: this library is no longer supported
npm WARN deprecated [email protected]: Please upgrade to latest, [email protected] or [email protected]! Check these notes:
npm WARN deprecated [email protected]: core-js@<3.23.3 is no longer maintained and not recommended for usage due to the number of issues. Because of the V8 engine whims, feature detection in old core-js versions could cause a slowdown up to 100x even if nothing is polyfilled. Some versions have web compatibility issues. Please, upgrade your dependencies to the actual version of core-js.

added 7 packages, removed 40 packages, changed 501 packages, and audited 1351 packages in 4m

110 packages are looking for funding
  run `npm fund` for details

8 vulnerabilities (1 moderate, 7 high)

To address all issues (including breaking changes), run:
  npm audit fix --force

Run `npm audit` for details.
npm notice 
npm notice New minor version of npm available! 8.15.0 -> 8.19.1
npm notice Changelog:
npm notice Run npm install -g [email protected] to update!
npm notice 

Appreciate any help! Thank you :pray:

Hey @jt7635,

Welcome to the community :tada:

I can’t see any errors in the output you posted, is there more to it?

Thanks Jon!

There isn’t any more to the output no (just process exited from Heroku console) - it seems an install process was carried out, but even after restarting my dyno and navigating back to the live link, N8N still showing as not updated (still 9 updates behind latest)

That is odd, I have not really used Heroku before. I have just looked at the link you posted though and it is using a container not npm.

When you run the command on Heroku is that running it in the custom container you deployed or on the Heroku instance?

It looks like you might need to update the Dockerfile to change the version then build and push the container again.

It looks someone has asked the same question about upgrading on the project itself here: How to update this to the new n8n version · Issue #48 · sarveshpro/n8n-heroku · GitHub

There is also a pull request on it to update it to 192.

Hello, maybe you forgot the @latest at the end of your command :

npm install -g [email protected]

Did you find any solution ? I got the same problem :

After doing the command in Heroku console I still got a lot of updates.

Hey @beatsfaty,

If you are using a git repo you would need to make a change in git for Heroku to re pull which is why using latest may not work.

Hello, no I used the “one click deploy”.

Also I did the npm install -g [email protected] on heroku console and everything was successful but version didn’t changed.

I also tried updating npm with heroku console but same thing ! Everything going well but still same version.

Hey @beatsfaty,

Which repo did you do the one click install from?

I don’t really remember it was 2 years ago but I think it’s the official one from the n8n documentation.

Hey @beatsfaty,

I don’t think we had an official one 2 years ago, But to update it you will need to update your Heroku git project from wherever you installed it from.

Our official one is here: GitHub - n8n-io/n8n-heroku but it would have the same problem where it would need a commit to update.

So I deploy again ?

Hey @beatsfaty,

If you can access the Heroku git repository your settings were showing you could change the version there and push a change which should trigger an update as well.

Hey @Jon , sorry I didn’t find, How can I do that ?

Hey @beatsfaty,

That I don’t know, I am not that familiar with Heroku. In your screenshot I noticed the Heroku git URL of is that not something you have access to?

Have you worked out where you installed n8n from yet as well, As it was 2 years ago it probably wouldn’t be ours so knowing that would also be a massive help.