Problems with a Box trigger node

Describe the problem/error/question

I can not get the Box trigger node to work. It keeps listening and does not do anything when I, for example, add a file to a specific folder.

What is the error message (if any)?

Request failed with status code 504

Please share your workflow

Share the output returned by the last node

Information on your n8n setup

  • n8n version:: Version 1.31.2

  • Database (default: SQLite): Postgress

  • n8n EXECUTIONS_PROCESS setting (default: own, main): ???

  • Running n8n via (Docker, npm, n8n cloud, desktop app): Docker on Synology installed via Portainer based on the instructions of Marius Hosting: How to Install n8n on Your Synology NAS – Marius Hosting

  • Operating system: Synology DSM 7.2

  • n8n is working fine after install

  • I use the reverse proxy of the Synology with a wild card and that also works. I can reach n8n via HTTPS

  • I can run nodes for Box as download a file or upload a file. Those work! The trigger file for Box does not work and keeps listening for a change. I need this trigger for a specific flow I want to build.

  • My ports 80 and 443 are forwarded on my router and open (checked online)

  • I tried to turn off the Synology firewall to see if that blocked the communication, but this did not make any changes

I am not very experienced with networking and completely new with n8n, so looking for some help… I am not sure if this is problem from the node itself or a structural system configuration problem which bothers the Box ‘listeing’ webhook?

If I have to add some extra info, please let me know.

Thanks in advance!

Daniel

I have an addition to my post:

  • I have tested with the Notion trigger node. This node works fine on a change in a Notion database. I belive however that this node works on polling.
  • I have also tested the webhook node with a test url and this also worked. When entering the url in a web browser I get the response that the workflow was started.

Welcome to the community!
Where are you running n8n? Self hosted or cloud plan?

If self hosted, please check your env variable N8N_EDITOR_BASE_URL and ensure it’s the full URL you’re using with https://

I spun up a test n8n instance and accidentally left out the https:// in that env variable and it caused the same web hook issue. Once I added the https:// it started working

Let me know if that’s the issue, if not I’ll have some more trouble shooting steps for you :grin:

Thank you Liam!

Sorry for the late reply. I forgot to turn on email notifications for replies on my topic.

I am running n8n self hosted.

There was no N8N_EDITOR_BASE_URL in my stack docker compose file on Portainer. I added it with my full https adress of the n8n instance and had the same problem I’m afraid.

If you have any other options, I would appreciate them very much.

Grtz!

Sorry for the delay. I actually left one out here, I think the URL that might matter for n8n’s webhooks is the WEBHOOK_URL env variable. try changing that one to the full https address if you havent already

Hi Liam, thanks again. That env variable is allready set to the full https adress.