Problems with accessing Google Drive

Hello good people :star_struck:
I’m on n8n cloud Running version [email protected]

I’ve been struggling with something so simple that I can’t believe I got stuck on it.
I’m trying to create new document in Google Docs. I’ve set up OAuth corretly. It must be correct beause when I use “Update” operation - I’m easily able to update existing document.
But when I’m trying to Create new document, I need to fill the Drive Name or ID field. According to n8n Documentation I shoud do this - " 3. From the Drive dropdown select which of your drives this file will be created in. My Drive is selected by default." But in my case, there’s no drop down list. I tried to put different names (my drive, My Drive, my-drive, drive), but nothing seems to work.
Any ideas?
Thanks in advance

Hey @Kris_Szostak,

If you click on the little dots above the Drive Name or ID field and click refresh does that change anything for you? If you wanted to type it in change the field to an expression and input myDrive.


Thanks @Jon. This helped me to execute the node and in the error message I got some info about API not configured properely. In Google console I enabled Google Sheets and Docs, but forgot to enable Google Drive. Enabling this sorted out the problem.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.