Problems with Facebook On Leads node in version 1.22.6

I created a new application on Facebook to be able to integrate with the Facebook on leads node.

It has already been followed as described on the page and I added what should be done in the places.

I activated authorizations and even added Subscribed Apps to set the necessary permissions.

But when I activate the listen test or activate the production flow I am receiving this message and I don’t know what to do.

Facebook Lead Ads Trigger: 400 - {“error”:{“message”:“(#2200) Callback verification failed with the following errors: HTTP Status Code = 404; HTTP Message = Not Found”,“type”:“OAuthException” ,“code”:2200,“fbtrace_id”:“AZU0JVa1qtaZf9mzzrkDo5R”}} - (#2200) Callback verification failed with the following errors: HTTP Status Code = 404; HTTP Message = Not Found

Could anyone give me some guidance?

It looks like your topic is missing some important information. Could you provide the following if applicable.

  • n8n version:
  • Database (default: SQLite):
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app):
  • Operating system:

Hey @Adonis_Cavalcanti,

Welcome to the community :raised_hands:

It looks like something is returning a 404, My first guess is maybe you are self hosting n8n and have not set WEBHOOK_URL so the webhook URL for the Lead Ads trigger is showing as http://localhost, Or you are using a tunnel and the tunnel url is no longer valid.

Sorry, this is the first time I’ve posted here in the community.

The installation used was via docker swarm and using traefik.

Postgress database

The operating mode of the N8N is queue mode

The installation was done on a Contabo VPS.

Operating system is Linux.

As shown in the image when I clicked on listen. The error is occurring.

@Jon The connection with the callback to authorize and search pages and forms worked as in the image above, but when I try to activate the workflow to wait for the event, it gives an error. Both in workflow test mode and in production mode

Hey @Adonis_Cavalcanti,

If you expand Webhook URLs under the Parameters does that say localhost?

Below are the prints of the two urls

webhook test

webhook production

@Jon

Those URLs look fine to me, I wonder if maybe the error is with the authentication. Does the Meta Developer portal for your application have any kind of logging in it?

Hi @Jon , here is the printout regarding the Facebook login and how it is currently.

This issue occurred in version 1.14.0 and 1.16.0 when they were implemented. And the version of my application in another was at version 17 and currently the meta is at 18.

I turned to the community because I literally can’t find the error.

Thank you in advance for your feedback.

Hey @Adonis_Cavalcanti,

What does the error at the top say? Callback verification does sound like facebook isn’t able to verify the url :thinking:

I have done a quick search online and it looks like the 2200 seems to mean that facebook isn’t able to connect to your host I am just not sure why that is. When you use the test option (listen for event) it will use the URL under test url and when activating it will use the production url.

Have you checked to see if a normal webhook node works for both the test and producution url?

Sorry for the delay in responding @Jon ,

Below is what happened in a webhook test in the user part

Unable to connect with test webhook

The production link also gave the same error. It’s as if there is no callback return

I really don’t understand what is going wrong. The person who developed the node would be nice. Carry out the tests in queue mode. And see if what is happening and in the integration documentation lists what needs to be available for integration with node to occur normally.

And also which environment in which node can receive the information, since the n8n can have a queue mode installation and another in regular mode

Hey @Adonis_Cavalcanti,

The node will work in both queue mode and normal mode, The tricky bit would be if you are using queue mode with webhook workers you would need to make your load balancer has the correct routing rules in place or you will get errors.

In this case it looks like Facebook is getting a 404 when trying to access the webhook so for some reason they are unable to reach your host or hte webhook url is not active properly. I have just done a quick test from here to the production URL in your screenshot and I get a 403 response around authorization not being valid which makes sense as you have a header there.

As to why Facebook specifically is showing a 404 it could be that they are being blocked or it wasn’t active at the time. It might be worth trying to connect to the same webhook url from a different machine yourself to see if you get an issue.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.