Production Webhook not registered

Hi! This is a great piece of software…thank you.

I’m trying to get the webhook working and am running into the issue when running curl:
curl -X POST but not when running curl -X POST

{“code”:404,“message”:“The requested webhook “POST t” is not registered.”}

Here’s my webhook code…super simple…works as expected with the test webhook but not the production. The webhook is saved and activated…have read through the posts here but nothing is working…thank you in advance!! Joel.

  "nodes": [
      "parameters": {
        "httpMethod": "POST",
        "path": "=t",
        "responseMode": "lastNode",
        "responseData": "allEntries",
        "options": {}
      "name": "Webhook",
      "type": "n8n-nodes-base.webhook",
      "typeVersion": 1,
      "position": [
      "webhookId": "6a73cc93-b4aa-4ab4-ac8b-1a78d6ba3141"
  "connections": {}

Welcome to the community @joelcrawford

This is quite weird. When you active the workflow, do you get an error?

That looks like a bug that we have to investigate. I guess nobody did ever try to set the path to an expression before.

Should I be looking for logs? Nothing is telling me through the UI that there is an error…

I guess so! I just recreated the webhook with the default path var and it works! Which is fine for now…

Let me know if you find out more about setting the path!

Thank you both

No thanks. Nothing needed from your side. We can reproduce the problem locally. I guess the issue is that resolving expression at that level got never implemented. For that reason does it also not throw an error as it is probably registered but wrong.

Just fixed the bug: 🐛 Fix bug with expression in production webhook paths · n8n-io/n8n@8f3bc32 · GitHub
Will be released with the next version.

Got released with [email protected]

Thanks @jan :slight_smile: