Rabbit MQ trigger node fails with AWS MQ instance

I have a Rabbit MQ trigger node that watches for messages in a queue. When executing the node manually I get the following error:
Frame size exceeds frame max

This error occurs even before inserting a message into the exchange/queue. It errors as soon as the node is executed and connection starts.

n8n version: 0.184.0
AWS Rabbit MQ version: 3.8.30

Hey @Gowthaman_Prabhu, are you by any chance running n8n behind a reverse proxy server or load balancer? This might cause trouble as RabbitMQ uses the AMQP protocol instead of the HTTP protocol which most reverse proxy servers are configured to handle. Check out their documentation on this topic:

https://www.rabbitmq.com/networking.html#intermediaries

There’s also other reports out there suggesting this could be down to the RabbitMQ ports being used by other applications:

Could this be a problem on your end as well?

@MutedJam Neither. No reverse proxy nor load balancer.

Hey @Gowthaman_Prabhu,

How do you have n8n installed?

@jon running n8n as a docker compose service on EC2

@Gowthaman_Prabhu Can you share your compose file? Are you just using EC2 or do you have other services involved as well like say Cloudflare.

@Jon

That looks to be ok, I take it you are not using HTTPS or port 443 to access n8n? Have you tried with the image we supply to see if the issue exists there as well?

1 Like

@Jon Thank you so much. I had to toggle SSL ON :confused: and that fixed it.

2 Likes