Read operation in google sheets error


After successfully authenticating a Google Sheets node, I get this error when trying to read a file.


“message”: “400 - {“error”:{“code”:400,“message”:“This operation is not supported for this document”,“status”:“FAILED_PRECONDITION”}}”,

“name”: “Error”,

“stack”: “Error: Request failed with status code 400 at createError (/usr/local/lib/node_modules/n8n/node_modules/axios/lib/core/createError.js:16:15) at settle (/usr/local/lib/node_modules/n8n/node_modules/axios/lib/core/settle.js:17:12) at IncomingMessage.handleStreamEnd (/usr/local/lib/node_modules/n8n/node_modules/axios/lib/adapters/http.js:269:11) at IncomingMessage.emit (node:events:532:35) at IncomingMessage.emit (node:domain:475:12) at endReadableNT (node:internal/streams/readable:1346:12) at processTicksAndRejections (node:internal/process/task_queues:83:21)”


I was able to copy the file for example, so cannot really figure out why read operation fails. Any suggestions on how to troubleshoot that?


Hey @Thanos_Daskalopoulos,

Is the file a Google Sheet or is it an Excel file?

it’s a google sheet

Is the spreadsheet ID just the ID from the URL? So if the sheet URL was:

The ID would be: 1xLbb3cxqE8xo-fqd-JLVu7ZW-UQJIH_l-BXOOGsr9dw

exactly. I used the ID in a google drive node and made a copy. That worked for example.

Is there another way to read the doc from the google drive? What does the download operation do when in environment?

The download operation would download the file to memory but it may not help, I have been having a play and a bit of a look around and I can’t find a reason as to why you would get that error.

Does it happen on all Google sheets? As a quick test can you set the ID of the sheet to 1fN47ZSp1VeliUswUY1cP4Yw0dBeqdgtBjXY_GOs7f1w and see if that works?

yes that works :thinking:

anything I might be missing on the google sheet settings side?

Nothing that I can think of, Can you share the document with me? Feel free to DM a link to it and I can take a look and see if I can open the same sheet here.

I found it, I was wrong in my original answer. I thought it was google sheet, as it was still as .xlsx in the drive. Did the transformation and it worked…sorry for the fuzz and thanks a lot.

1 Like

That is good to hear, It was the the first thing I was going to check with the document just to make sure. Glad it is all working now though :+1: