Receiving undefined despite having a working expression

Describe the issue/error/question

I receive undefined despite having a working expression.

What is the error message (if any)?


Please share the workflow

Share the output returned by the last node

As you can see next, the node SET is working perfectly, but I’m receiven an undefined or null in some values.

This expression is for DIA, and it’s working against the first row (the one showing undefined)

Here are the results, showing undefined or null, even though I’m seeing a value on Result.
Screenshot 2022-12-15 at 17.26.09

Hey @masudjuan,

Can you share the input items? I suspect the problem could be that there is some data missing somewhere in the input, This can happen if there are multiple items coming in.

1 Like

I continued to search for the issue, and I was not able to find it. Anyway, I find a turnaround that actually works, but it’s not actually solving the previous bug.

I’ll show all the nodes here:

As you can see here, my problem was happening on the node in the red box. It was receiving a “date” value , that somehow was not reading it (and it was showing an actual value)

I find out that the “date” that it’s coming from the Gmail node, is not actually working somehow. I, instead, used the “Header->Date” value and format it with a Date Time node (blue box), and it’s now working.

I’m not sure why the gmail “date” value is not working.

I tried using pinned data with the same data generated by the Gmail node and it was working, but somehow with the Live data was not working (and as I already explained, the live data is coming with values, no null or undefined)

Hey @masudjuan,

That picture shows a lot, So while the node might have had the data as you are using $json which loops the input items rather than the specific node and there are 5 items coming into the set it could be that one of those 5 has lost it on the way. We see this sort of thing fairly often (3 times today so far) so it would be a case of checking the multiple executions or adding a quick if node to check if it is empty

It sounds like you are mostly sorted now though which is nice.

@Jon , thanks for your help so far. Do you have a recommendation of how to connect many nodes to 1? The IF was added in the expression. I’m validating that the value is not coming null, but somehow is not validating well against the value.

I probably have a bug somewhere, it’s a long run until the node that presents the problem. But I’m thinking that the Gmail Node is somewhat not sending correctly the Date parameter.

Long story short, the problem now is solved with another approach, but thanks for your help!

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.