Reddit category error

Hello guys.i have been using reddit node before without problem.
but now when i want to do anything with reddit node, it gives me this error :

Workflow has issues
Please fix them before executing:

  • Reddit: Parameter “Category” is required.

Information on your n8n setup

  • **n8n version:latest
  • **Database you’re using (default: SQLite):default
  • **Running n8n with the execution process [own(default), main]:default
  • **Running n8n via [Docker, npm, n8n.cloud, desktop app]:Docker

Hi @rhodesgod, I am so sorry for the trouble. It sounds like you might be affected by the bug fixed here for a bunch of other nodes but not Reddit :frowning:

I’ll add this to our internal bug tracker for a closer look. You might need to downgrade your n8n version until this is fixed (or use the HTTP Request node instead).

2 Likes

Hey @rhodesgod,

I have just popped in a PR to fix this one, I am going to do a quick check to see if anything else is impacted.

3 Likes

oh ok.
no problem. I’ll wait for the update.
I thought i’m doing something wrong, so this is a bug.

Thank you for the info.

2 Likes

Yeah it is a bit of an annoying one but we are planning to have it fixed in the next release which is normally a weekly thing and we are only a couple of days away so not long to wait :raised_hands:

3 Likes

Got released with [email protected]

2 Likes

thanks.it’s working now

1 Like