Rocketchat Integration [GOT CREATED]

Free Open Source Team Chat similar integration to send to a room/DM would be amazing!

I agree here… RC integration would be fantastic.

I would like RC! Please :heart_eyes:

@BCEVE @kasini which use case are you looking for?

Sending messages to individual(s), groups, channels would be a great start!
Being able to change the “FROM”, Avatar would be amazing as well.
I’m currently doing it via a hack with Curl which I could share.

@tiredofit Perfect, I’m working on the fresh desk integration right now as soon as I finish it I might be able to look into this. Never used Rocketchat but it seems like the slack integration has a lot of similarities.


Very sorry, did not get to it earlier. Is now released with [email protected]
Thanks a lot @RicardoE105 for creating it!


Many Thanks RicardoE105. I only wish that I had the skills that you had to turn this around so fast.


@RicardoE105 I seem to be having no success with trying to test this out.

In my Rocket API I use the username provided along with the Token, yet I seem to be having some trouble with your field subdomain. I have tried: https://domain/api https://domain/api/v1 yet get an error of

Error: Rocketchat Error: TypeError: Cannot read property 'body' of undefined
    at Object.executeSingle (/usr/local/lib/node_modules/n8n/node_modules/n8n-nodes-base/dist/nodes/Rocketchat/Rocketchat.node.js:463:27)
    at processTicksAndRejections (internal/process/task_queues.js:93:5)

I also tried without the protocol in front and received 280kb of response but it bogged down so much I couldn’t see much other than the first line which was DOCTYPE HTML etc. Any advice on where I am going wrong on this?

Hey @tiredofit I have a test account you can check.

Subdomain: n8n
UserID: initialuser
Auth key: Vu0LJVWVXMUO1mhBdM_xysnjcKXPtM-wJUq7A7g3Cf9

To get the userId which is not your username and the auth key you gotta login and grab them from the response.

You can do that doing a POST to the following end point youdomain/api/v1/login and providing the fields username and password on the body.

Let me know if that helps.

Sorry about my delay in getting back to you, had a few things to take care of before I went back at this. The workspace has expired - and that is OK. I think where the issue is here is with the subdomain field - Rocketchat does have a hosted option, but really shines in it’s on premise implementation. Perhaps subdomain can be altered to take a FQDN?

@tiredofit yeah I can change it to take the whole domain instead of just the subdomain. Gonna send a pull request with this fix. Thanks for pointing that out.

@RicardoE105 Thanks a lot for making the change.

Got released with [email protected]

1 Like

Hi @RicardoE105 - I’m back at this to test, I still can’t seem to get it to work properly. What gets out put is 220kb of data and when looking at it it is the source of the front page requesting authentication.

I’m not sure what I’m doing wrong as if it is related to an on premise install vs their hosted.
My user ID and password is correct (based on the curl tests).
My domain is simply https://(myrocketchat.domain)

Attempting to send a chat message either to channel or user provides the 220kb response of the initial html webpage.

@tiredofit Just saw the issue. I sent a pull request to fix it. In the meantime just add /api/v1 to your domain and then try again. Should be like this https://(myrocketchat.domain)/api/v1.


Hi @RicardoE105 Thanks for prompt response. Indeed it is working with the additional /api/v1 attached on the end. I can successfully send to a channel. I cannot however send to a “@user” for some reason, is there a trick?

@tiredofit with users you gotta use @ instead of #.

Released fix of @RicardoE105 with [email protected]

1 Like

Hi @RicardoE105 Yes thanks, I was using it with @ but just had a facepalm moment, I was trying to send to myself as a test. Of course it wouldn’t work. Is all sorted, we are loving this, thanks for being patient and creating this once again.

1 Like

@tiredofit be aware That if you update to the last version of n8n you gotta remove the /api/v1

1 Like