We need an RSS Trigger, e.g. for Crunchyroll news and so on
Oh didnât saw that I could use a rss reader ⊠But anyway I think it would be better if it would be a trigger because then new users wouldnât have any difficulties and can just use it simpler
Agreed Zapier has an RSS trigger that executes whenever news comes in - this is much nicer than running on a cron schedule
EDIT: Looks like @Jon created a community node - awesome! Iâm happy to be a guinea pig on this one.
Links:
I did indeed make one, I have been using it to keep an eye on some software update feeds and the wtf1.com news feed ![]()
Hi @Jon ,
I am using the n8n-nodes-rss-feed-trigger, everything works fine, but when I go to activate the workflow, I get the following error:
I am forgetting something?
Thanks in advance
Information on your n8n setup
- n8n version: 0.214.0
- Database youâre using (default: SQLite): SQLite
- Running n8n with the execution process [own(default), main]: own
- Running n8n via [Docker, npm, n8n.cloud, desktop app]: Docker
Hey @martinhache,
Can you try restarting your container and seeing if that helps?
Hey @jon, what do you mean by ârestarting your containerâ ? I get the exact same error of @martinhache
Hey @comedepreville,
Welcome to the community ![]()
Pretty much what it says, restart the container. This is assuming you are running in docker if you are using npm it would just be a case of restarting n8n.
Loud and clear. Thanks @Jon !
Hi @Jon,
Could it be that with the last update to 0.221.2 the n8n-nodes-rss-feed-trigger does not work correctly?
I have restarted the container and the parameter âpollTimesâ does not appear in the node.
Thanks in advance
Information on your n8n setup
- n8n version: 0.221.2
- Database youâre using (default: SQLite): SQLite
- Running n8n with the execution process [own(default), main]: own
- Running n8n via [Docker, npm, n8n.cloud, desktop app]: Docker
Hey @martinhache,
There was a change in 221.0 that stopped the poll times from being displayed, This should be resolved in the next release.
Perfect!
Thank you @Jon
like @Jon said, I restarted my container, after the installation of the plugin, and after the creation of the node but still have a problem when I try to activate the workflow
My setup is
- n8n Version 0.221.2
- RSS Feed Trigger v0.1.3
Workflow could not be activated:
- There was a problem activating the workflow: âCould not get parameter âpollTimesâ!â
it that package still maintained?
Hey @JOduMonT,
The fix is in 0.222.0 of n8n so you would need to do an update. As far as I know the package is still maintained, I have not made any updates for a while to is as it doesnât need any. It looks like the message in your screenshot is an npm error and not related to the package.
Sorry I mixed up version semantic for once.
Thank you @Jon. This is awesome! Self hosting and using your rss trigger has saved me $$$.
That is always good to hear and welcome to the community ![]()
Hi there, I am using the self-hosted version n8n 1.0.5 and the same issue happens again
Workflow could not be activated: There was a problem activating the workflow: âCould not get parameter âpollTimesâ!â
What should i do?
here is the code i copied from n8n;
{
âmetaâ: {
âinstanceIdâ: âMASKED IDâ
},
ânodesâ: [
{
âparametersâ: {
âfeedUrlâ: âTorrent Invites - #1 To Buy, Trade, Sell Or Find Free Tracker Invites!â
},
âidâ: âMASKED IDâ,
ânameâ: âRSS Feed Triggerâ,
âtypeâ: ân8n-nodes-rss-feed-trigger.rssFeedTriggerâ,
âtypeVersionâ: 1,
âpositionâ: [
840,
580
]
},
{
âparametersâ: {
âchatIdâ: â@MASKED IDâ,
âtextâ: â={{ $json.pubDate }}\n{{ $json[âcontent:encodedSnippetâ] }}â,
âadditionalFieldsâ: {}
},
âidâ: âMASKED IDâ,
ânameâ: âTelegramâ,
âtypeâ: ân8n-nodes-base.telegramâ,
âtypeVersionâ: 1,
âpositionâ: [
1040,
580
],
âcredentialsâ: {
âtelegramApiâ: {
âidâ: âMASKED IDâ,
ânameâ: âTelegram accountâ
}
}
}
],
âconnectionsâ: {
âRSS Feed Triggerâ: {
âmainâ: [
[
{
ânodeâ: âTelegramâ,
âtypeâ: âmainâ,
âindexâ: 0
}
]
]
}
}
}
Hey @tobywong080,
Try restarting your n8n instance again, I had to do it with my instance before it appeared again.


