Running IF false first then True

Hi Everyone,

How to NOT run an IF condition with both statements at the same time?

Wondering how can I make the flow of an IF condition, of FALSE running first and then only after this, I run the TRUE statement? Both statements communicate with the same endpoint, but I need to perform this in order not to hit the rate limit request!

Any good advice? Thank you very much.

Hi @Jorge_M, I am not sure I fully understand the question. You have one IF node which will send items to both the true and the false output? And you want the ones sent to the false output to run first?

Could you maybe share your workflow?

@MutedJam I have similar question.

I have a check to see if the customer is new or not. In this test my database was empty, so the Insert new record node inserted successfully.

My question is, then why the false also trying to run? Of course it failed because it can’t find an existing id to update.

The check is simple, just length of searching data

Hi @Sang

Usually you check a value vs a fixed value.
In your screenshot there is 2 expressions in the check. What are those expressions set to?

Are they both as shown?

Ps. There is also an “is empty” option in the if node

1 Like

@BramKn Thank you! I get it now. Now I know I have to set the value 2 correctly. I was wrong when I selected Boolean condition option but then compare number with number!

I changed to {{true}} and now it works as expected!

Have a nice weekend @BramKn